Degraded App Performance (Slowness & Lagging)
Incident Report for Help Scout
Resolved
We've been able to implement a fix and are seeing app performance improve. We'll continue to keep an eye on things just in case, but feel free to reach out to us at help@helpscout.com if you see further issues.
Posted Jun 03, 2024 - 12:14 EDT
Identified
We've been able to identify the source of the issue and are working on a solution.
Posted Jun 03, 2024 - 11:47 EDT
Update
We're still investigating issues with app slowness - we appreciate your patience and will share updates once we have them.
Posted Jun 03, 2024 - 11:12 EDT
Investigating
We've noticed an issue with general app performance and are actively investigating.
Posted Jun 03, 2024 - 10:31 EDT
This incident affected: Web App.