Speed across Help Scout is back to normal, so we're closing this out. If your team continues to see any issues with Help Scout, please reach out to our team. Thanks again for your patience and apologies for the issues experienced today!
Posted Sep 23, 2024 - 13:07 EDT
Update
Our team is still investigating the issue with slowness in Help Scout. Thanks for your patience today!
Posted Sep 23, 2024 - 12:34 EDT
Update
We are continuing to investigate this issue.
Posted Sep 23, 2024 - 12:04 EDT
Update
Our engineers continue investigating this issue, which is impacting the speed of page loads across Help Scout. We will provide more updates as we have them. We appreciate your patience!
Posted Sep 23, 2024 - 11:33 EDT
Investigating
We're looking in to reports of slow page loads across the app. Some customers may notice a long delay when working in Help Scout. We'll update here when we have more information.