Our engineers got to the bottom of today's issues and have released a fix. Performance should be returning back to normal across the board. We apologize for the disruption to your day.
Posted 2 months ago. Feb 13, 2025 - 11:20 EST
Update
We're seeing improvements in the performance of the Docs editor and inbound and outbound emails are working in Inbox. We're still working on getting Apps, Messages, and Chat working smoothly.
Posted 2 months ago. Feb 13, 2025 - 10:57 EST
Update
We're seeing improved performance in Inboxes, but pages are still struggling to load for Apps, Messages, and the Docs editor. Our engineers are continuing to work on a solution.
Posted 2 months ago. Feb 13, 2025 - 10:16 EST
Identified
We've identified the cause of the issues creating slowness across Help Scout and are working on implementing a solution. We'll keep you informed on our progress -- thanks for your patience.
Posted 2 months ago. Feb 13, 2025 - 09:50 EST
Investigating
We're looking in to reports of slow page loads across the app. Some pages are not loading at all. We'll update here when we have more information.
Posted 2 months ago. Feb 13, 2025 - 09:45 EST
This incident affected: Web App, Docs Sites, Email Processing, and Mailbox counts, folders, reports, search results.