Inboxes Not Currently Loading For Some Users

Incident Report for Help Scout

Resolved

Our team identified and fixed this issue and all pages across the app should be loading normally now. Apologies for the disruption today, folks!
Posted Feb 19, 2026 - 16:00 EST

Monitoring

A fix has been implemented and our team is monitoring results.
Posted Feb 19, 2026 - 15:52 EST

Investigating

We're looking in to reports of trouble loading Inboxes across the app. We'll update here when we have more information. Thanks for your patience!
Posted Feb 19, 2026 - 15:32 EST
This incident affected: Web App, Email Processing, and Mailbox counts, folders, reports, search results.