Slow Page Loads
Incident Report for Help Scout
Resolved
We've found the source of the issue and have solved the issue with page loads. Thank you for your patience!
Posted Aug 01, 2024 - 11:19 EDT
Update
We're continuing to investigate the situation causing slow page loads. Thank you for your patience!
Posted Aug 01, 2024 - 10:46 EDT
Investigating
We're investigating reports of slow page loads across the app. Some customers may notice a delay when attempting to use Help Scout. We'll update you as soon as we have more information.
Posted Aug 01, 2024 - 10:14 EDT
This incident affected: Web App.