Attachment Download/Email Delay Issues
Incident Report for Help Scout
Resolved
We’re closing this out now that we’ve remediated the issue with attachments upon arrival, sorry for the trouble today! New emails are being processed as expected, and we’re working to figure out a path forward for emails received during this period that still show issues with attachments and the “Show Original” thread option.

Impacted customers may hear from us as we continue to investigate the next steps to resolve outstanding attachment issues, but do reach out in the meantime if you have questions on this front.
Posted Jan 02, 2024 - 07:21 EST
Monitoring
Our team identified the root cause of the issue impacting incoming emails and has implemented a fix. This fix also resolves issues with new incoming attachments. We're currently investigating to see if previously affected attachments can be downloaded, and we will update this incident when we have more to share.
Posted Jan 02, 2024 - 06:57 EST
Investigating
We’re looking into issues downloading and viewing attachments, and a delay with inbound emails. We'll update here when we have more information.
Posted Jan 02, 2024 - 06:30 EST
This incident affected: Web App.