Email Delays
Incident Report for Help Scout
Resolved
Email queues are just about empty, so we're closing this one out, friends! Apologies for the trouble!
Posted Sep 20, 2021 - 07:37 EDT
Identified
Our engineers have identified the issue, and while email delivery is still delayed, we're working on getting the queues clear as quickly as possible.
Posted Sep 20, 2021 - 07:27 EDT
Investigating
We're investigating a problem with delays affecting outgoing email messages. We'll post more information here as we have it.
Posted Sep 20, 2021 - 07:10 EDT
This incident affected: Email Processing.