Inbound Email Delays
Incident Report for Help Scout
Resolved
The app is stable and running smoothly and all emails have now been processed. Thank you for your patience while we resolved this
Posted Mar 09, 2022 - 23:01 EST
Monitoring
The backlog of inbound emails have been cleared. The app is now running smoothly and emails are being processed correctly. We'll continue to monitor the situation.
Posted Mar 09, 2022 - 22:42 EST
Identified
We're currently seeing a delay in processing incoming emails. Our engineers have identified the cause and we'll follow up with more updates shortly.
Posted Mar 09, 2022 - 22:06 EST
This incident affected: Email Processing.