Slow Page Loads Throughout App
Incident Report for Help Scout
Resolved
The third party issue appears to be resolved and the app is now running smoothly.
Posted Sep 10, 2024 - 00:26 EDT
Update
We are continuing to investigate this issue.
Posted Sep 09, 2024 - 22:12 EDT
Update
A third party issue is affecting performance across the app for users in some locations. Our team will continue to investigate and provide updates.
Posted Sep 09, 2024 - 22:07 EDT
Investigating
Our team is investigating reports of slow page loads across the app. Some customers may notice a delay when attempting to use or log into Help Scout. We'll update you as soon as we have more information.
Posted Sep 09, 2024 - 21:56 EDT
This incident affected: Web App and Mailbox counts, folders, reports, search results.