Engineers have confirmed queues have drained and Reports behavior is stable across the board, so we're closing this out. Thank you for your patience while we worked on this one!
Posted Aug 06, 2026 - 13:26 EDT
Monitoring
Our Engineering Team has identified the root cause of delayed/inaccurate reports and a fix is in place. However, there is a backlog of reports that needs to process before things are fully caught up. Reports will take some time to normalize - we will continue monitoring.
Posted Aug 06, 2026 - 13:10 EDT
Identified
Our Engineering Team has identified the root cause of the report loading issues and are working to bring them back online.
Posted Aug 06, 2026 - 12:55 EDT
Investigating
We’re currently investigating reports of issues with loading Reports. We will continue to update as we have more information.
Posted Aug 06, 2026 - 12:12 EDT
This incident affected: Mailbox counts, folders, reports, search results.