Connection Issues

Incident Report for Help Scout

Resolved

We've been able to resolve the issues with slow page loads across Help Scout. We appreciate your patience and welcome you to reach out to Help Scout Support via help@helpscout.com with any follow-up questions.
Posted 1 year ago. Apr 19, 2024 - 12:42 EDT

Identified

We've identified the source of the issue, and we're working on remediation; periodic slowness may continue in the meantime.
Posted 1 year ago. Apr 19, 2024 - 12:16 EDT

Update

We are still investigating the slow page loads across Help Scout. Thanks for bearing with us.
Posted 1 year ago. Apr 19, 2024 - 11:49 EDT

Update

We are still investigating the slow page loads across Help Scout. Thanks for bearing with us.
Posted 1 year ago. Apr 19, 2024 - 11:14 EDT

Update

We continue to investigate the slow page loads across Help Scout. Thanks for bearing with us.
Posted 1 year ago. Apr 19, 2024 - 10:42 EDT

Investigating

We're looking into reports of slow page loads across the app. We'll update here when we have more information.
Posted 1 year ago. Apr 19, 2024 - 10:20 EDT
This incident affected: Web App.