Degraded Performance & Slow Loading Issues

Incident Report for Help Scout

Resolved

The issue has been identified & resolved, and everything should be back to normal once again. Thank you for your patience with this!
Posted Sep 15, 2025 - 10:11 EDT

Identified

Our engineers have identified an issue with a recent deployment that likely caused this degraded performance. We've got a fix coming shortly that'll take care of those slow page loads. We'll post here again once everything is back to normal. Thanks for your patience while we investigate!
Posted Sep 15, 2025 - 09:56 EDT

Investigating

We're looking into reports of slow page loads across the app. Some customers may notice longer-than-usual loading times when working with Help Scout in both Inbox & Docs. Our engineers are on it, and we hope to have news on a resolution for this as soon as possible.
Posted Sep 15, 2025 - 09:25 EDT
This incident affected: Web App.