Views and folders should now be updating as expected and show all matching conversations. Thank you for your patience today.
Posted Sep 09, 2025 - 20:55 EDT
Update
We've identified and released a fix for issue that was affecting our app. The fix is now live and you should see normal performance returning over the next few hours as the fix fully takes effect. No action is needed on your end.
We apologize for any inconvenience this may have caused and appreciate your patience while we fully resolve this issue.
Posted Sep 09, 2025 - 18:29 EDT
Update
We are continuing to work on a fix for the issues with Views. Thanks for your understanding as we get everything working again today!
Posted Sep 09, 2025 - 17:30 EDT
Identified
Our team has identified the issue which has caused degraded performance across Views. We're still seeing delays, but we've identified the issue and we're working on a fix. We'll post an update when we've got more news to share.
Posted Sep 09, 2025 - 17:00 EDT
Investigating
We are investigating an issue with Views not properly updating in Help Scout, which is causing conversations to not appear in matching views. We'll post more information here as we have updates. Thank you for your patience!
Posted Sep 09, 2025 - 16:45 EDT
This incident affected: Web App, Beacon, and Mailbox counts, folders, reports, search results.