Connections Issues

Incident Report for Help Scout

Resolved

The issue has been fully resolved, and all systems are operating normally. Thanks for your patience while we worked through this!
Posted Jun 24, 2025 - 09:14 EDT

Monitoring

The issue has been identified and a fix has been implemented. We're currently monitoring to ensure everything remains stable. Performance should be back to normal for most users.
Posted Jun 24, 2025 - 09:07 EDT

Investigating

We are investigating an issue where users are reporting slow page loads across the app. We'll share updates as soon as possible.
Posted Jun 24, 2025 - 08:56 EDT
This incident affected: Web App, Email Processing, and Mailbox counts, folders, reports, search results.