Folder counts, message previews, search results and new email processing are in the clear. We're closing this one out. Apologies for the trouble this Friday morning!
Posted Sep 11, 2020 - 06:58 EDT
Investigating
We’ve been alerted to a problem with Help Scout - we’re investigating. You may see a delay for new emails in search, folder counts may be not updating correctly, and workflows may be delayed in running.
Posted Sep 11, 2020 - 06:41 EDT
This incident affected: Mailbox counts, folders, reports, search results.