Email Delays
Incident Report for Help Scout
Resolved
We've resolved the issue that was causing an intermittent delay in email processing, so we're closing this one out. Apologies for the trouble!
Posted Jun 25, 2022 - 15:33 EDT
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Jun 25, 2022 - 14:30 EDT
This incident affected: Email Processing.